Resolve aclocal is missing

Resolve aclocal is missing

If you ever build package from a tarball then maybe you can find sometimes there is another part is missing. One of them is aclocal. This program is a part of GNU Automake package. The error message from bash shell is like this:

WARNING: ‘aclocal-1.13’ is missing on your system.
You should only need it if you modified ‘acinclude.m4’ or
‘configure.ac’ or m4 files included by ‘configure.ac’.
The ‘aclocal’ program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
make: *** [aclocal.m4] Error 127

You are very sure that the aclocal is right in your server but somehow the configuration script cannot find it. So use this command line step from your bash shell to overcome this kind of error.

$ sudo aclocal
$ sudo automake –add-missing
$ sudo ./configure
$ sudo make

The line 2 from the above command will fix the error of aclocal is missing. Now you can try reconfigure again and install your package. Hope this information can help you.

Leave a Reply

Your email address will not be published. Required fields are marked *